Dai-Sukima Dan Forums: Demo Black Screen - Dai-Sukima Dan Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Demo Black Screen Windows10

#1 User is offline   Raineh Daze Icon

  • Newbie
  • Pip
  • Group: Members
  • Posts: 5
  • Joined: 04-February 13
  • LocationUK

Posted 05 November 2015 - 01:51 AM

Since upgrading, I've been unable to run the second demo for ESR on Windows 10 without a black screen. Trying to run the .py file directly hasn't worked, either. Worked on 8, though.

#2 User is offline   LTalon Icon

  • Newbie
  • PipPipPip
  • Group: Lead Writer
  • Posts: 604
  • Joined: 11-November 09

Posted 10 November 2015 - 06:02 AM

Is this issue still occurring? What build are you using?

Sorry about the delayed response; our usual debug guy is out, but this LT will do his best to figure out what's going on.

#3 User is offline   SleepKirby Icon

  • Newbie
  • PipPipPip
  • Group: Developer
  • Posts: 100
  • Joined: 23-June 10

Posted 14 November 2015 - 12:51 PM

Another developer (Graph) also had a Windows 10 issue with older versions of Ren'Py. In his case he got some kind of silent error when trying to start up the game (in Ren'Py's development environment). Nothing seemed to happen when running the .exe, but he then noticed there was a log file that was updated with an error. When he updated his Ren'Py development version to the latest one, he was able to get past this startup issue.

It's possible that we could re-build demo 2 with a newer version of Ren'Py that Windows 10 works better with. No guarantees that it'll work, since our demo 2 code assumes older Ren'Py, but we could give it a shot.

Before attempting that though, does Windows 10 have some kind of compatibility mode that you can run the game with?

#4 User is offline   Graph Icon

  • Newbie
  • Icon
  • Group: Manager & Lead Artist
  • Posts: 471
  • Joined: 11-November 09

Posted 17 November 2015 - 11:25 PM

To clarify on that, my problem actually came up when using a fairly recent version of Ren'py in Windows 10. That was 6.99.x, but not the latest version at the time; the latest version seems to do fine on Windows 10. I haven't been able to reproduce it on the demo.

But yeah, until I know more my suggestion is to try right-click -> Properties -> Compatibility, then try using the troubleshooter or Compatibility mode.

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users